Free Shipping on Everything.
60-Day Money-Back Guarantee | Lifetime Tech Support

2003 jeep liberty renegade

Car Audio, Video, & GPS

Car Audio, Video, & GPS
Talk about stereos, navigation, amps, subs, and all things car audio

2003 jeep liberty renegade

This question is answered

Front speakers all quit working any ideas

Verified Answer
  • Check all your wiring first. Some versions of the Liberty have a stock Infinity amp system. If all your speakers went at once, then it is probably a problem with the amp and not all of the speakers. Typically, speakers don't just all blow at the same time unless you have changed the system somehow. Since you have not done that, then the problem is probably with something that is a common source to all the speakers. In this case, if it is the Infinity system, then it is more than likely a factory amp issue. Sometimes is is simply a turn-on lead that has come loose and the amp is not turning on or it could be an actual problem with the output on the amp.

    I hope this helps and gets you started with the trouble-shooting.

  • I'm not sure it's a factory amp issue.

    From what I can access of the Infinity wiring, one amp powers the left side and one amp powers the right side.

    So if both speakers on one side were out, then an amp issue seems likely - but if both front speakers are out, that would mean the front channels on both amps failed, but the rears are still working.

    Dumb question - but you did verify the fader isn't accidentally set fully to the rear, correct?

    If not, then it seems like it would either be wiring or the front channels on the HU have gone bad.

    You could isolate it by swapping HU wires, but that means splicing into the factory wiring, or swapping front and rear speakers on one side, but with the Infinity system the amp is physically mounted to the speaker, so that isn't really feasible, or just replace things until it starts working again.

    Hope This Helps!!!

    Anyone else have suggestions?

    2002 Ford Focus JVC KD-A815 Sony CDX-GT410u Sony XT-100HD HD Tuner Stock speakers, no amp, no subs

All Replies
  • what is your set up? Stock ,aftermarket, amps etc.

    05 Silverado xtra cab, Eclipse 3200 HU, MTX 150/2 bluethunder frt., MTX 75/2 bluethunder rear, MTX 800/1 subs, Alpine SPX 6.5 seperates frt& rear, 2-12" Infinity reference subs in down firing sealed box, 2 farad cap, copius dynamat.

  • Nothing but stock

  • Check all your wiring first. Some versions of the Liberty have a stock Infinity amp system. If all your speakers went at once, then it is probably a problem with the amp and not all of the speakers. Typically, speakers don't just all blow at the same time unless you have changed the system somehow. Since you have not done that, then the problem is probably with something that is a common source to all the speakers. In this case, if it is the Infinity system, then it is more than likely a factory amp issue. Sometimes is is simply a turn-on lead that has come loose and the amp is not turning on or it could be an actual problem with the output on the amp.

    I hope this helps and gets you started with the trouble-shooting.

  • I'm not sure it's a factory amp issue.

    From what I can access of the Infinity wiring, one amp powers the left side and one amp powers the right side.

    So if both speakers on one side were out, then an amp issue seems likely - but if both front speakers are out, that would mean the front channels on both amps failed, but the rears are still working.

    Dumb question - but you did verify the fader isn't accidentally set fully to the rear, correct?

    If not, then it seems like it would either be wiring or the front channels on the HU have gone bad.

    You could isolate it by swapping HU wires, but that means splicing into the factory wiring, or swapping front and rear speakers on one side, but with the Infinity system the amp is physically mounted to the speaker, so that isn't really feasible, or just replace things until it starts working again.

    Hope This Helps!!!

    Anyone else have suggestions?

    2002 Ford Focus JVC KD-A815 Sony CDX-GT410u Sony XT-100HD HD Tuner Stock speakers, no amp, no subs