Free Shipping on Everything.
60-Day Money-Back Guarantee | Lifetime Tech Support

Kenwood DNX7100 Software Update 1.0.9

Car Audio, Video, & GPS

Car Audio, Video, & GPS
Talk about stereos, navigation, amps, subs, and all things car audio

Kenwood DNX7100 Software Update 1.0.9

  • Software update version 1.0.9 is now available for the Kenwood DNX7100.

    You will need your serial number to gain accesses to the update download site.

    http://www.kenwood.com/usb/mm_fwdl_en.html

    This update adds functionality for the newer iPods and some other minor fixes.

    It also fixes the slow indexing of USB drives.

    My software version was 1.0.2 before the update.

    The software download includes a PDF instruction page on how to perform the update. Read it closely before starting.

    !!Important!! When you start the update the screen will go black for about 1 or 2 minutes before it shows the update being installed. Be patient and DO NOT turn off the DNX7100 or disconnect the USB drive. I don't know for sure but that may cause a problem.

    My update went smoothly and only took a few minutes to perform.

    USB indexing now works very fast!!



    [edited by: Nice Pony at 11:01 AM (GMT -5) on Fri, Jan 04 2008]
  • Sweet! Thanks a ton for the update info Nice Pony.
    www.crutchfield.com/Malcolm
  • hmmmm.  does it work fast enough for a 120 gig portable harddrive?
  • This upgrade also solved the longstanding problem I'd been having with my Sirius Connect tuner, where the Sirius radio display would frequently start up in a "waiting" state until I toggled back and forth between sources or stations.  I went through *three* of those tuner boxes before I finally gave up and figured I'd have to live with the problem permanently. 

    Who knew the fix would be a firmware upgrade -- when I called Kenwood last year they told me the HU firmware was not user-upgradable.  Mine was originally on 1.0.1.

  • Hello! 

     

    I had been using a Kingston DataTraveler 4GB USB flash drive full of MP3 files for months with no problems except the slow indexing (SW ver 1.0.2). I bought a Kingston DataTraveler 8GB USB flash drive to increase music capacity (before the update) and the DNX7100 would not recognize it and reported "No Device". When I plugged the 4GB back in the DNX7100 immediately responded with "reading..." or similar message and started playing in seconds. I ejected the 4GB and tried the 8GB and again no response. The 8GB works fine on any computer I have tried. It is FAT32 format, just like the 4GB and the file structure is the same, just more files.

     

    Then I did the SW update to 1.0.9 hoping that might fix things but there was no change with the 8GB (although the 4GB indexes much faster).

     

    Any hints about what might be wrong? I will try to find another brand of 8GB USB drive to borrow and try that as my next step. 

     

    Thanks,  Carl 

  • You may need to get the software update that Nice Pony referenced in his post at the beginning of the thread. Try that update and let us know if it works.

     http://www.crutchfield.com/bio/Paul

  • I did install the update to 1.0.9 (I even installed the separate Garmin firmware update for the Nav section). No help.

     

    Very rarely, the DNX7100 will recognize the 8Gb flash drive and when it does, it reads it and works perfectly. However, this rarely happens. I'm fairly sure it's not a connector problem because once it is working, it will work perfectly as long as the power is on even if I am driving over rough roads. However, when I turn off the car, it does will not read it the next time I start up. The 4 Gb (same brand and model) reads flawlessly every time.

     I also tried resetting the DNX7100 (it erased all my presets) but that did not help. I did try another identical size and brand flash drive to see if the failed one could be damaged but it behaved the same. I have not yet tried an 8Gb flash drive from another manufacturer but that is my next experiment.

    Best regards,

     

    Carl
     

  • under which menu can i look and see which version i have as far as updates for my dnx7100?

     

    thanks.

     

  • Try the Sandisk 8GB SDHC Card.  I've tried several other 8GB thunb drives and the 7100 never recognized them but it always reads the Sandisk.  You can buy them on eBay for about $20 and it comes with the USB adapter reader.
  • this is the one I just bought  and its working great and reads pretty fast, holds about 100 cds 

    http://www.amazon.com/gp/product/B0012X5766

     

  • Once you download software update V.1.0.9. and the other two documents (PDF files).  How do you transfer the file (data) into the DNX7100?  Can I use an SD card?  Nowhere in the instruction does it say how to transfer the data into the DNX7100. Try to contact Crutchfield to ask this question thru they support, however “No Help.”  Maybe you can help me out since you done it already and it work for you.

     

     

  • Not sure if you are still following this thread, but I think the initial post implied using a USB flash drive.

    Hope This Helps!!!

    2002 Ford Focus JVC KD-A815 Sony CDX-GT410u Sony XT-100HD HD Tuner Stock speakers, no amp, no subs

  • Ok I been using a 8 gig Flash drive for months now no problem. Just a few days ago I went to try to use it via the USB selection on main screen and it started reading but it stays on same song which isn't the first song and the menu for next track/folder stay inactive/unlighted. I did try to perform this update but first problem was extracting the second winzip file it had alot of errors..anyway I tried installing the fisrt update for the unit I presume and nothing it won't bother to start a read of the SD card at all. Nothing was in folders SD card only has files on it. Now my 8 gig thumb drive works fine everywhere else tested. I even tried using another thumb drive I think it was a 1 or 4 gig thumb drive with same file folder I use for music and it goes directly for the same song and plays it back to back. Whats could be wrong here?
  • I recently bought an iPod touch which recommended installing the latest firmware update for my DNX7100 before connecting it using Kenwood's special iPod audio and video adapter.  I performed the update to 1.0.9 from my previous version of 1.0.2.  Immediately afterwards I attempted to use the 4GB usb drive which I've been using without any problems for months now and it would not read it.  Sometimes it gets stuck in a reading status and others it simply doesn't recognize it at all.  I'm planning on running the update again to see if that's all it takes to fix it but just wanted to check and make sure I'm not missing something else more trivial.  I am waiting on the iPod connector to come in the mail and hope that at least that will work if I lose the ability to use the usb.  Also, I was wondering if there is a way to go back to a previous version of firmware.

    Any and all advice would be greatly appreciated.

     

    Thanks 

  • mattcm32:
    Also, I was wondering if there is a way to go back to a previous version of firmware.

    I can't say for sure with Kenwood, but with most devices you can flash whatever firmware version you want onto the device, IF you still have the older version firmware.

    Hope This Helps!!!

    2002 Ford Focus JVC KD-A815 Sony CDX-GT410u Sony XT-100HD HD Tuner Stock speakers, no amp, no subs