Car Audio, Video, & GPS

Car Audio, Video, & GPS

Car Audio, Video, & GPS
Talk about stereos, navigation, amps, subs, and all things car audio
Browse Forums
Forum Posts
Amplifiers How to hook them up, where to put them, etc. 4,011
EQs, Crossovers, and Sound Processors Tips for fine-tuning your sound 37
General Car A/V Discussion Talk about other gear and car audio topics 4,360
Receivers Choosing, installing, and using a new car receiver 3,474
Speakers Tips for choosing and installing new car speakers 2,332
Subwoofers Hooking up and tuning bass systems in the car 4,531
Forum - Thread List
Topic Date Replies
Announcement

Here are some helpful Speaker tips from Crutchfield

Posted to: Speakers
Latest post
  • 3

Subs won't work

Posted to: Subwoofers
Latest post
  • 1

RCA Home speakers

Posted to: Speakers
Latest post
  • 0

Backup Camera Connection

Posted to: General Car A/V Discussion
Latest post
  • 0

Jl bass

Posted to: Amplifiers
Latest post
  • 1

Amp RCA inputs

Posted to: Amplifiers
Latest post
  • 1

Do I Need to Install a Crossover?

Posted to: General Car A/V Discussion
Latest post
  • 12

Volume Too Loud at Lowest Setting

Posted to: General Car A/V Discussion
Latest post
  • 1

MLV install question

Posted to: General Car A/V Discussion
Latest post
  • 2

6 speaker layout: how best to build and wire?

Posted to: Speakers
Latest post
  • 15

USB random doesn't random

Posted to: General Car A/V Discussion
Latest post
  • 1

2016 Tundra Crewmax Entune Speakers

Posted to: Speakers
Latest post
  • 1

2 Subs, 2 Mono Amps

Posted to: Subwoofers
Latest post
  • 1

Why need cable to connect USB drive?

Posted to: General Car A/V Discussion
Latest post
  • 1

Subwoofer Delay?

Posted to: Subwoofers
Latest post
  • 5

White noise after installing amp to speakers

Posted to: Amplifiers
Latest post
  • 6

Why does my front speakers now make noise after installng a amp for...

Posted to: General Car A/V Discussion
Latest post
  • 6

Axxess ASWC-1 problem

Posted to: Receivers
Latest post
  • 0

Clarion CX505 bluetooth problem

Posted to: Receivers
Latest post
  • 0

Help choosing between Pioneer AVH-2800BS and Kenwood DDX374BT

Posted to: Receivers
Latest post
  • 2

Amp is on but no sound

Posted to: Amplifiers
Latest post
  • 1

How to adjust my input sensitivity

Posted to: Amplifiers
Latest post
  • 2

Trying to build box for two hertz 12" subs

Posted to: Subwoofers
Latest post
  • 29

Screen Goes Black

Posted to: Receivers
Latest post
  • 3

2001 Pontiac Grand Am GT amplified Monsoon system wire harness?

Posted to: Amplifiers
Latest post
  • 1

SETUP STOPPED WORKING!!!

Posted to: Subwoofers
Latest post
  • 8

Pandora has no sound...

Posted to: Receivers
Latest post
  • 0

Car amplifier for specific speakers (Bose SE 151)

Posted to: Amplifiers
Latest post
  • 8

2channel KAC-729S with 4 speakers

Posted to: Amplifiers
Latest post
  • 1

Installing LOC - I need help

Posted to: Amplifiers
Latest post
  • 3

Which subwoofer?

Posted to: Subwoofers
Latest post
  • 5

Pontiac Grand Am Gt

Posted to: Speakers
Latest post
  • 26

Amp and speaker questions

Posted to: Amplifiers
Latest post
  • 6

Mercedes wiring question

Posted to: General Car A/V Discussion
Latest post
  • 9

PIoneer DEH 80PRS

Posted to: Receivers
Latest post
  • 3

How Long Does a Typical CD Receiver Last?

Posted to: General Car A/V Discussion
Latest post
  • 3

Wiring Help Please

Posted to: Subwoofers
Latest post
  • 1

Amplifier stopped working!!!!

Posted to: Amplifiers
Latest post
  • 1

2003 Oldsmobile alero

Posted to: Speakers
Latest post
  • 1

No call audio MVH-X690BS

Posted to: Receivers
Latest post
  • 2

Odd receiver problem

Posted to: General Car A/V Discussion
Latest post
  • 4

Odd Subwoofer issue....Inconsistent bass

Posted to: Subwoofers
Latest post
  • 1

2009 Ford Taurus SWI 2 wire location help.

Posted to: Amplifiers
Latest post
  • 8

Pioneer 6200 2009 Ford Taurus no power?

Posted to: Receivers
Latest post
  • 3

Finding an Amp for 4 speakers

Posted to: Amplifiers
Latest post
  • 11

BAD AMP???

Posted to: Amplifiers
Latest post
  • 3

Need repair info on an Earthquake PA2150 amp.

Posted to: Amplifiers
Latest post
  • 3

Lots of Static 1990 BMW 325

Posted to: General Car A/V Discussion
Latest post
  • 2

Weird audio problem with car stereos

Posted to: General Car A/V Discussion
Latest post
  • 2

2013 F150 -XL - Non Integrated radio

Posted to: Receivers
Latest post
  • 9

2003 Tahoe NoN-Bose, no sound from front speakers.

Posted to: General Car A/V Discussion
Latest post
  • 3

07CVR124 Wiring Question

Posted to: Subwoofers
Latest post
  • 9

4-channel LOC with Y-splitters vs. 6-channel LOC

Posted to: General Car A/V Discussion
Latest post
  • 4

Fused distribution block

Posted to: Amplifiers
Latest post
  • 5

Amp Suggestion

Posted to: Amplifiers
Latest post
  • 1

Svc snd dvc both 4 ohms help me please im a girl trying to figure...

Posted to: Subwoofers
Latest post
  • 3

Buying 2 Alpine Type R Subs!! Help!

Posted to: Subwoofers
Latest post
  • 16

Weird sub hitting when turning off

Posted to: Amplifiers
Latest post
  • 4

2 ohm or 4 ohm

Posted to: Speakers
Latest post
  • 5

Proper Grounding

Posted to: Amplifiers
Latest post
  • 3

H/U internal amplifier stack with Alpine PowerPack?

Posted to: Amplifiers
Latest post
  • 4

Rear speakers cut out amplifier?

Posted to: Amplifiers
Latest post
  • 1

sub wiring

Posted to: Subwoofers
Latest post
  • 1

Subwoofer Feedback!

Posted to: Subwoofers
Latest post
  • 1

What Are The Best Navigation Systems Currently On Market

Posted to: Receivers
Latest post
  • 0

Help please kenwood ksc-sw11 underseat sub problem

Posted to: Subwoofers
Latest post
  • 4

PLEASE HELP!!! AUDIO SQ BUILD! NEED RECOMMENDATIONS

Posted to: General Car A/V Discussion
Latest post
  • 2

VM audio amplifiers

Posted to: Amplifiers
Latest post
  • 1

Orion competition subwoofer and amplifier

Posted to: Subwoofers
Latest post
  • 1

Wiring subs

Posted to: Subwoofers
Latest post
  • 2

Ohm stability

Posted to: Subwoofers
Latest post
  • 2

Set up Kenwood head unit

Posted to: Receivers
Latest post
  • 4

Nascar cup series auto parts 50% OFF

Posted to: Speakers
Latest post
  • 0

2015 Ford Focus, Adding a Powered Sub

Posted to: Subwoofers
Latest post
  • 1

hissing/buzzing noise in tweeters

Posted to: Speakers
Latest post
  • 1

Help with ivc KW-v820 BT

Posted to: Subwoofers
Latest post
  • 0

Aftermarket Subwoofer?

Posted to: Subwoofers
Latest post
  • 1

4 speakers to a 2 channel amp

Posted to: Speakers
Latest post
  • 1

Car audio tuning.

Posted to: Subwoofers
Latest post
  • 8

Help with new Yamaha receiver

Posted to: Receivers
Latest post
  • 0

New Stereo Help!

Posted to: Receivers
Latest post
  • 2

Jvc receiver doesn't turn on

Posted to: Receivers
Latest post
  • 3

Pioneer MVH-X380BT Phone Call Problems

Posted to: Receivers
Latest post
  • 3

2208 pontiac G6

Posted to: Receivers
Latest post
  • 1

What amp for JL 12w3v3-4?

Posted to: Amplifiers
Latest post
  • 18

2005 Jeep Grand Cherokee Limited Aftermarket Stereo HELP

Posted to: General Car A/V Discussion
Latest post
  • 1

Right-Front Speaker not working correctly

Posted to: General Car A/V Discussion
Latest post
  • 1

Kicker 43C104

Posted to: Subwoofers
Latest post
  • 1

Looking for a really good shallow 8" sub.

Posted to: Subwoofers
Latest post
  • 1

2015 Jeep Wrangler AVH-X4800bs Bluetooth Issue

Posted to: Receivers
Latest post
  • 1

F-150 Supercrew design help

Posted to: Subwoofers
Latest post
  • 3

Subwoofer question (space)

Posted to: Subwoofers
Latest post
  • 3

Which subwoofers should I get?

Posted to: Subwoofers
Latest post
  • 1

NB Miata rear fill speakers

Posted to: Speakers
Latest post
  • 9

Audiosource210 Power Amp

Posted to: Speakers
Latest post
  • 0

BOSE Amplifier

Posted to: Amplifiers
Latest post
  • 0

12 volt switched

Posted to: Receivers
Latest post
  • 0

Sudden Onset Speaker Distortion

Posted to: Speakers
Latest post
  • 0

Amp help

Posted to: Subwoofers
Latest post
  • 1

How to setup/power my subs/amp!

Posted to: Subwoofers
Latest post
  • 1