Car Audio, Video, & GPS

Car Audio, Video, & GPS

Car Audio, Video, & GPS
Talk about stereos, navigation, amps, subs, and all things car audio
Browse Forums
Forum Posts
Amplifiers How to hook them up, where to put them, etc. 4,011
EQs, Crossovers, and Sound Processors Tips for fine-tuning your sound 37
General Car A/V Discussion Talk about other gear and car audio topics 4,360
Receivers Choosing, installing, and using a new car receiver 3,474
Speakers Tips for choosing and installing new car speakers 2,332
Subwoofers Hooking up and tuning bass systems in the car 4,531
Forum - Thread List
Topic Date Replies

Pioneer GM-D8601 options to give sub 400w

Posted to: Amplifiers
Latest post
  • 3

Any Toby know it all out there? How much are they worth???

Posted to: Subwoofers
Latest post
  • 8

Stereo issue

Posted to: General Car A/V Discussion
Latest post
  • 1

4ohm vs 2ohm which to get?

Posted to: Subwoofers
Latest post
  • 1

Hissing when on but no audio playing

Posted to: General Car A/V Discussion
Latest post
  • 8

1997 Ram 1500

Posted to: General Car A/V Discussion
Latest post
  • 1

JL Audio 13" TW5 2 ohm or 4

Posted to: Subwoofers
Latest post
  • 1

line converter or active crossover??

Posted to: General Car A/V Discussion
Latest post
  • 1

Revised installation subwoofer output very weak

Posted to: General Car A/V Discussion
Latest post
  • 18

Car receiver to amp rca connection question

Posted to: Amplifiers
Latest post
  • 5

Help

Posted to: Subwoofers
Latest post
  • 2

Extremely frustrating Pioneer XM radio software issue, please help...

Posted to: Receivers
Latest post
  • 1

BT Streaming Problems

Posted to: General Car A/V Discussion
Latest post
  • 1

CONTACTS SYNC WITH KENWOOD DDX393

Posted to: Receivers
Latest post
  • 1

1993 gmc radio

Posted to: General Car A/V Discussion
Latest post
  • 2

Pre amp voltage vs gain

Posted to: Amplifiers
Latest post
  • 1

2006 Honda Odyssey Touring without Nav - upgrade audio

Posted to: General Car A/V Discussion
Latest post
  • 1

Clarion NZ503 GPS stop working

Posted to: Receivers
Latest post
  • 6

Subwoofer placement in a 2005 Dodge Dakota Quad Cab

Posted to: Subwoofers
Latest post
  • 1

Replacement Amp - 2004 Jeep Wrangler

Posted to: Amplifiers
Latest post
  • 1

attenuation help

Posted to: EQs, Crossovers, and Sound Processors
Latest post
  • 3

Is my amp too powerful?

Posted to: Subwoofers
Latest post
  • 1

2012 Chevy Silverado extended cab - new amp install

Posted to: Amplifiers
Latest post
  • 5

Best value High quality head?

Posted to: Receivers
Latest post
  • 1

component speakers (tweeters not working)

Posted to: Speakers
Latest post
  • 8

Factory satellite not retained

Posted to: General Car A/V Discussion
Latest post
  • 1

High Price Amps Really Worth the Extra Money?

Posted to: Amplifiers
Latest post
  • 1

First time installing car audio with 2 speakers and 4 channel amp...

Posted to: General Car A/V Discussion
Latest post
  • 3

New Kenwood HU DNX572BH No Bluetooth, Microphone Or USB Functions

Posted to: Receivers
Latest post
  • 1

What sub and amplifier/s should I use?

Posted to: Amplifiers
Latest post
  • 1

Get bass without external amplified sub?

Posted to: Speakers
Latest post
  • 1

Amp wires

Posted to: Amplifiers
Latest post
  • 5

Amp won't turn on

Posted to: Amplifiers
Latest post
  • 5

Intermittent audio while driving only

Posted to: General Car A/V Discussion
Latest post
  • 1

New to audio world, need help choosing speakers

Posted to: Speakers
Latest post
  • 1

Speaker help

Posted to: Speakers
Latest post
  • 4

Subs with stock speakers?

Posted to: Subwoofers
Latest post
  • 1

More feel and less sound?

Posted to: Subwoofers
Latest post
  • 1

Kicker Front Row speaker pop

Posted to: EQs, Crossovers, and Sound Processors
Latest post
  • 1

Dual DC535Bi

Posted to: Receivers
Latest post
  • 1

Amplifier/Subwoofer: Not playing sound from Subwoofer

Posted to: General Car A/V Discussion
Latest post
  • 1

Good Stereo System Without Subwoofer

Posted to: Speakers
Latest post
  • 1

Custom 6x9 box build help.

Posted to: Speakers
Latest post
  • 12

Mono output, bridged 4ch amp

Posted to: Subwoofers
Latest post
  • 62

Amplifier Settings

Posted to: Amplifiers
Latest post
  • 4

Pioneer DEH-150MP wiring

Posted to: Receivers
Latest post
  • 1

Alpine Type-R

Posted to: Subwoofers
Latest post
  • 1

Audio Newbie

Posted to: Speakers
Latest post
  • 5

Car stereo keeps resetting when the car is turned off

Posted to: Receivers
Latest post
  • 3

Amp and Sub set up

Posted to: Subwoofers
Latest post
  • 1

Pioneer DEH-6800BT

Posted to: Receivers
Latest post
  • 1

Kenwood dnx572bh help

Posted to: General Car A/V Discussion
Latest post
  • 5

Need Help with 7 speaker setup.

Posted to: Amplifiers
Latest post
  • 6

Buzzing noise-but not when vehicle is in ACC mode

Posted to: Speakers
Latest post
  • 9

3 alpine Swr-d2's, what amp?

Posted to: Amplifiers
Latest post
  • 1

Alpine SWS-10D4

Posted to: Subwoofers
Latest post
  • 3

subwoofer enclosure options- Cerwin Vega VPRO122D (x2)

Posted to: Subwoofers
Latest post
  • 2

Will these be a good pair?

Posted to: Subwoofers
Latest post
  • 5

Help With Bridging Amp. Thought I Knew

Posted to: Amplifiers
Latest post
  • 5

Do i need 2ohm or 4ohm?

Posted to: Subwoofers
Latest post
  • 1

Cooling my amp

Posted to: Amplifiers
Latest post
  • 7

amp has power, no sound from subs

Posted to: Amplifiers
Latest post
  • 3

Amp help

Posted to: Subwoofers
Latest post
  • 3

Head unit output to bike comm system Input

Posted to: General Car A/V Discussion
Latest post
  • 1

Can anyone help me find my perfect receiver?

Posted to: Receivers
Latest post
  • 1

Amp and Sub install using Scosche FAI-3AInstalling

Posted to: Amplifiers
Latest post
  • 1

I need some help figuring out what I need

Posted to: Amplifiers
Latest post
  • 1

Kenwood DDX418 - Playing video files from USB drive.

Posted to: General Car A/V Discussion
Latest post
  • 13

Infinity Primus PR6500cs

Posted to: Speakers
Latest post
  • 2

Multiple amps help!

Posted to: Amplifiers
Latest post
  • 37

2001 Toyota Sequoia w JBL System

Posted to: General Car A/V Discussion
Latest post
  • 1

JL Sub Recommendation

Posted to: Subwoofers
Latest post
  • 2

Door Speakers stopped working, need help please!!

Posted to: General Car A/V Discussion
Latest post
  • 6

mounting marine speakers with speed clips

Posted to: Speakers
Latest post
  • 1

Impedance selectors on dvc subs?

Posted to: Subwoofers
Latest post
  • 13

GLI question

Posted to: EQs, Crossovers, and Sound Processors
Latest post
  • 3

What's this?

Posted to: General Car A/V Discussion
Latest post
  • 3

Sub/Amp Wiring

Posted to: Subwoofers
Latest post
  • 5

Possible bad new subs?

Posted to: Subwoofers
Latest post
  • 1

bass blockers

Posted to: General Car A/V Discussion
Latest post
  • 4

Ford rear support bracket with Pioneer receiver.

Posted to: Receivers
Latest post
  • 1

Sirius Antenna

Posted to: Receivers
Latest post
  • 2

Little space but want a lot of bass 10s or 8s

Posted to: Subwoofers
Latest post
  • 1

How to tune a new car stereo?

Posted to: Receivers
Latest post
  • 3

Baselink fades out

Posted to: Subwoofers
Latest post
  • 2

Kenwood DNN991HD: "Unfortunately the process android.process...

Posted to: General Car A/V Discussion
Latest post
  • 1

Help finding an amp

Posted to: Amplifiers
Latest post
  • 7

Blaupunkt New Jersey 220 BT with added subs

Posted to: Receivers
Latest post
  • 1

Balanced Output Signal from Factory Head Unit to After-Market Amp...

Posted to: Amplifiers
Latest post
  • 3

Letter S highly pronounced at high volume

Posted to: EQs, Crossovers, and Sound Processors
Latest post
  • 1

Alpine dual SWT-10S2 wiring

Posted to: Amplifiers
Latest post
  • 1

Sony CDX-L410X Faceplate Warning De-Activation Questions.

Posted to: Receivers
Latest post
  • 19

2006 Subaru STI Pioneer Fitment Issue

Posted to: Receivers
Latest post
  • 1

2011 Pilot Factory Head Unit Sub humming

Posted to: General Car A/V Discussion
Latest post
  • 1

Can I pair a 2700w dvc 4ohm Sub with a 1700w 1ohm stable amp?

Posted to: Subwoofers
Latest post
  • 1

Alpine X305s With Imprint H100 Issue , Professional Help is needed

Posted to: EQs, Crossovers, and Sound Processors
Latest post
  • 1

HELP! Want Upgrade factory sub speaker

Posted to: Subwoofers
Latest post
  • 1

Speakers going in and out..

Posted to: Speakers
Latest post
  • 1

dead battery

Posted to: Amplifiers
Latest post
  • 3

blown fuse

Posted to: Amplifiers
Latest post
  • 5