Free Shipping on Everything.
60-Day Money-Back Guarantee | Lifetime Tech Support

Car Audio, Video, & GPS

Car Audio, Video, & GPS

Car Audio, Video, & GPS
Talk about stereos, navigation, amps, subs, and all things car audio
Browse Forums
Forum Posts
Amplifiers How to hook them up, where to put them, etc. 4,002
EQs, Crossovers, and Sound Processors Tips for fine-tuning your sound 37
General Car A/V Discussion Talk about other gear and car audio topics 4,353
Receivers Choosing, installing, and using a new car receiver 3,470
Speakers Tips for choosing and installing new car speakers 2,329
Subwoofers Hooking up and tuning bass systems in the car 4,527
Forum - Thread List
Topic Date Replies

Head unit failing?

Posted to: General Car A/V Discussion
Latest post
  • 1

2006 Ram 2500 Factory Stereo Receiver with 6 cd changer

Posted to: General Car A/V Discussion
Latest post
  • 1

Amp has power, but no sound (sometimes)

Posted to: Amplifiers
Latest post
  • 6

sound

Posted to: Receivers
Latest post
  • 1

No output to subs

Posted to: Amplifiers
Latest post
  • 5

Q: are playlists supported on Alpine HD149BT with with USB FlashDrive...

Posted to: Receivers
Latest post
  • 7

Can't get a buzz

Posted to: General Car A/V Discussion
Latest post
  • 3

Help needed wiring 4 6x9's and 1 sub to 4 channel amp

Posted to: General Car A/V Discussion
Latest post
  • 2

Kenwood radio help

Posted to: Receivers
Latest post
  • 1

97 ram 1500 w/ infinity stereo, front speaker amp bypass?!?!?!

Posted to: Speakers
Latest post
  • 1

How could I have blown my speaker, I don't get it????

Posted to: Speakers
Latest post
  • 1

No sound!

Posted to: General Car A/V Discussion
Latest post
  • 3

Explanation of Dodge H/U amp wiring needed.

Posted to: General Car A/V Discussion
Latest post
  • 1

Subwoofer/ amp going into protect mode.

Posted to: Subwoofers
Latest post
  • 1

Infinity Kappa 100.9 question

Posted to: Subwoofers
Latest post
  • 3

Alpine HU (CDE HD149BT) "vs" Pandora -- BT is up, but just...

Posted to: Receivers
Latest post
  • 1

Rockford Fosgate R400-4D Help

Posted to: Amplifiers
Latest post
  • 3

Low bass in rear speakers

Posted to: Speakers
Latest post
  • 4

system wire help

Posted to: Amplifiers
Latest post
  • 5

Voltage drop in 1 of 2 amps

Posted to: General Car A/V Discussion
Latest post
  • 1

Subwoofers

Posted to: Subwoofers
Latest post
  • 1

Subwoofers

Posted to: Subwoofers
Latest post
  • 1

Alternator Questions

Posted to: General Car A/V Discussion
Latest post
  • 1

Too many $&#$ crossovers! Help 2 setup/optimize 'modern'...

Posted to: EQs, Crossovers, and Sound Processors
Latest post
  • 7

sealed or ported in my trunk?

Posted to: Subwoofers
Latest post
  • 27

Front speaker?

Posted to: Speakers
Latest post
  • 3

Boat amp/speaker wiring install questions

Posted to: General Car A/V Discussion
Latest post
  • 1

Speakers emitting emi noises... Now nothing

Posted to: Receivers
Latest post
  • 2

Subs won't work! Help please!

Posted to: EQs, Crossovers, and Sound Processors
Latest post
  • 1

Subwoofer

Posted to: Subwoofers
Latest post
  • 1

What should i use to power my subs

Posted to: Subwoofers
Latest post
  • 3

Help! 05 Silverado Issues

Posted to: General Car A/V Discussion
Latest post
  • 3

Where do I start?

Posted to: Subwoofers
Latest post
  • 1

Hard Hitting Subwoofer Problem

Posted to: Subwoofers
Latest post
  • 6

Pioneer Appradio 4

Posted to: Amplifiers
Latest post
  • 3

head unit troubles

Posted to: General Car A/V Discussion
Latest post
  • 2

2003 Toyota Sequoia Radio Diagram and Steering Wheel Controls

Posted to: General Car A/V Discussion
Latest post
  • 1

03 grand am with monsoon

Posted to: Subwoofers
Latest post
  • 1

Hooking up an alpine r 15 1522D

Posted to: Subwoofers
Latest post
  • 1

Subwoofer Boxes...

Posted to: Speakers
Latest post
  • 1

subs

Posted to: Speakers
Latest post
  • 1

Need help picking out parts for the 370z!

Posted to: Amplifiers
Latest post
  • 8

Tweeters with Coaxial Speakers

Posted to: Speakers
Latest post
  • 1

Gains

Posted to: Amplifiers
Latest post
  • 2

Possible to Wire Separate Tweeters to Coaxial speakers?

Posted to: Speakers
Latest post
  • 3

Matching Subwoofer impedance to amplifier

Posted to: Subwoofers
Latest post
  • 7

New speakers underpowered

Posted to: Speakers
Latest post
  • 2

No more bass on rear 6x9

Posted to: Speakers
Latest post
  • 5

Best external mic for bluetooth head unit

Posted to: General Car A/V Discussion
Latest post
  • 1

Amp and Sub

Posted to: Amplifiers
Latest post
  • 1

What amp do i need?

Posted to: Amplifiers
Latest post
  • 3

2003 Grand Am W/ Monsoon

Posted to: General Car A/V Discussion
Latest post
  • 3

New Head Unit, Performance Change.

Posted to: Subwoofers
Latest post
  • 1

2005 Acura TL Total Upgrade

Posted to: Speakers
Latest post
  • 1

Help with popping

Posted to: General Car A/V Discussion
Latest post
  • 2

What gauge wire to use

Posted to: Amplifiers
Latest post
  • 2

Can you check over my selection before I buy?

Posted to: General Car A/V Discussion
Latest post
  • 8

LOUD buzzing from door speakers

Posted to: General Car A/V Discussion
Latest post
  • 4

Car audio cuts out as I increase the volume

Posted to: General Car A/V Discussion
Latest post
  • 1

Subs for 15 ram 1500 cc

Posted to: Subwoofers
Latest post
  • 1

Choosing Audio/Tech Vendor

Posted to: General Car A/V Discussion
Latest post
  • 1

car wont start with breaker closed

Posted to: Amplifiers
Latest post
  • 1

Rear-most speakers in Ford Excursion

Posted to: Speakers
Latest post
  • 0

Cutting out/distortion issues.

Posted to: Speakers
Latest post
  • 2

Amp and Line Output Converter on but no sound.

Posted to: Amplifiers
Latest post
  • 2

2013 Jeep Wrangler Upgrade questions!

Posted to: Amplifiers
Latest post
  • 1

Im at a loss...

Posted to: Subwoofers
Latest post
  • 3

Wiring tweeters with coax speakers

Posted to: Speakers
Latest post
  • 1

amp for 3 10s

Posted to: Amplifiers
Latest post
  • 1

Looking for best amp and box for my 3 12" jl w3v3's

Posted to: Amplifiers
Latest post
  • 1

Looking for help with right kind of amp for subs

Posted to: Subwoofers
Latest post
  • 1

Bluetooth Audio on AVH-X2700BS

Posted to: Receivers
Latest post
  • 6

Replacing rear deck speakers

Posted to: Speakers
Latest post
  • 5

Scratching noise coming from sub

Posted to: Subwoofers
Latest post
  • 3

Increase preamp voltage?

Posted to: General Car A/V Discussion
Latest post
  • 1

2 out of 4 speakers stopped working

Posted to: General Car A/V Discussion
Latest post
  • 1

2006 toyota highlander - Sudden loss of power to after market radio

Posted to: Amplifiers
Latest post
  • 1

No sound in 2006 Jeep Grand Cherokee with aftermarket stereo

Posted to: General Car A/V Discussion
Latest post
  • 1

box design

Posted to: Speakers
Latest post
  • 1

2012 Altima, adding Hi/Low with Bose Radio

Posted to: Amplifiers
Latest post
  • 1

Head unit stays ON after disconnecting ground

Posted to: Receivers
Latest post
  • 1

Wiring 4 speakers + 1 sub to a 4 channel amp.

Posted to: Amplifiers
Latest post
  • 1

Looking for some clarity

Posted to: Speakers
Latest post
  • 2

Help!!

Posted to: Speakers
Latest post
  • 3

pioneer avh-x3700 USB won't read drive

Posted to: Receivers
Latest post
  • 1

Suggestion needed for replacement of Factory fitted Audio System

Posted to: General Car A/V Discussion
Latest post
  • 1

speaker installation

Posted to: Speakers
Latest post
  • 1

02 buick lesabre

Posted to: General Car A/V Discussion
Latest post
  • 1

1 subwoofer bridged vs. 2 regular subwoofers

Posted to: Subwoofers
Latest post
  • 4

gmos lan adapter wiring

Posted to: Receivers
Latest post
  • 6

Any 2015-16 Chevy Colorado owners out there?

Posted to: Speakers
Latest post
  • 0

No Android Auto support for Pioneer AVH-4000NEX

Posted to: Receivers
Latest post
  • 5

Hooking up a Power Amp Denon DCA 550

Posted to: Amplifiers
Latest post
  • 2

Need another turn-on wire

Posted to: Amplifiers
Latest post
  • 3

polk vs infinity 6.5 speakers

Posted to: Speakers
Latest post
  • 1

Alpine iva w900

Posted to: Receivers
Latest post
  • 1

Brand new head unit no sound?!?

Posted to: Receivers
Latest post
  • 1

DNN991hd kenwood excelon

Posted to: Receivers
Latest post
  • 2

What amplifier would match up well with a single Alpine type R 12...

Posted to: Amplifiers
Latest post
  • 2

Hard to Use Car Stereos

Posted to: General Car A/V Discussion
Latest post
  • 0